Problema de corriente en la bomba de gasolina

Buenas amigo corseros un saludo y bendiciones para todos. Tengo un problema de corriente con la pila de gasolina la cual está directa bajo switch. Osea cuando pasó el switch se activa. Se que no es el funcionamiento correcto pero desd que compre el carro ha estado así. Bueno saque la pila y la probé en batería y fino activa. Ya le hice pruebas a los fusibles y están bien. Hice una prueba que un amigo corsero comentó por acá que puentiara en el reled los pines 85con 86 u 85 con 87 que activa directo. Bueno la hice y me activó. Pero al rato vuelvo hacer la prueba y ya no hace nada. El caso de todo es que no tengo corriente positiva ni señal para que active el relay

El relé de la bomba lo activa la ECU desde una de sus salidas. Anexo enlace de tutorial donde podrás apreciar pines ECU.

Verifica le llega voltaje Completo 12 Volt DC al relé midiendo en el terminal (86) de la base en condiciones originales.
Revisa los conectores en la ECU, que este bien ajustados y que exista continuidad desde el pin/terminal hacia el cableado. Hay oportunidades que la señal existe en la salida de la ECU pero el enchufe está sulfatado, suelto o sin continuidad y la señal no llega a su destino o llega muy débil.
Revisa continuidad al cable asociado a activar el relé de la pila, midiendo continuidad desde terminal del conector en ECU y Terminal (86) en la base del relé.

Buenas noches mis amigos. Gracias por la información lastimosamente me quedé sin bateria en el tlf y no pude ver esta valiosa ya que andaba en la calle varado información pero gracias a Dios pude resolver. Resulto ser el cable que utilizaron para puntiar el positivo de la pila que estaba haciendo un mal contacto. Y bueno quiero ponerlo a funcionar como debe de ser sin ese puente que tiene de switch y con esta información estudiaré y vere como hacerlo. Mil gracias y bendiciones a la familia corsera

Lo más fácil es que, como ya sabes cuál es el cable que está haciendo el puente lo sigas y lo quites, asegurándote que no hayan cables picados en el camino. Eso debería regresar la pila a su funcionamiento normal.

Gracias Mariano eso mismo voy hacer incluso lo deje a la vista para hacerlo este fin con calma