Inyector fallando

Buenas noches amigos, ando con un problema con el corsita desde hace poco, de repente ando en la vía y se apaga un inyector y es arrecho mantenerlo así, luego al buen rato vuelve a encender y anda de lo mas normal, ya lo cambie de posición y de cables y aun sigue el problema, mi pregunta es ¿sera que el inyector ya llego a su fin? y la única marca que encuentro por ahí es iridium no se si sea buena o no, que me recomiendan?

Mi pana cuando cambiaste el inyector de posición fallaba el mismo inyector? No será la bobina lo que falla?

sigue fallando ese mismo inyector, lo que hice fue que el inyector que falla le puse el cable del 2 cilindro y continuo la falla en el mismo inyector, es decir descarte cableado, para terminar de descartar saque los inyectores 1 y 2 y los alterne para verificar todo en el cilindro 1 (que es el que anda fallando) y funciono correctamente, mi pregunta es como saber si ese inyector ya llego a su fin de vida? y por supuesto la marca que me recomiendan

Pana tu mismo tienes que darte esa respuesta debido a las pruebas que hiciste

Manda a probar los inyectores en un sitio donde los limpien y que le hagan pruebas con parametros en bajas y altas rpms, con eso no hay caídas

La cuestion es que he leido que falla de suciedad es que se queda abierto o goteando el inyector en mi caso deja de funcionar y vuelve de nuevo, de hecho hoy estuvo de maravilla jaja, otra pregunta que puedo hacer es si le monto uno nuevo afectara el hecho que este nuevo y los demas antiguos?

No debería afectar si los demás están trabajando bien, aunque lo mas sano es verificar que los 4 estén trabajando igual, para esto es la prueba en la maquina

Mas que problema de suciedad tu inyector pudiera tener es un problema con la bobina lo que hace que bajo ciertas condiciones deje de funcionar (ver este video para entender de que hablo youtube.com/watch?v=FZXQd0xvYvY  )

Al momento de comprar el o los los inyectores trata de que sean los originales baja impedancia para corsa

Solucionado, era la bobina, estaba usando una nueva comprada hace poco y al parecer ese era todo el problema, la cambie por la vieja y listo! ahora anda serenito el carro! gracias por las respuestas!