Falla de mi corsa Speed

Buenas tardes Tengo un corsa Speed automatico año 2006
Recientemente le hice el motor completo, un mes y medio despues de hacer el motor se le puso una falla de perdida de fuerza procedi a llevarlo un mecanico que me hizo lo siguiente:
Mecanico 1
Cambiar damper nuevo
Cambiar Bobina nueva
Cambiar cables de bujias
Cambiar bujias
Cambiar polea de l tiempo
Una vez que cambie todo eso me mando a que lo llevara a otro lugar donde le metieran el escaner
me fui a un segundo taller
donde me indicaron que el problema era el sensor MAP, lo cambie y continuaba la falla al 5to dia de tenerlo me lo entregaron sin dar con la falla.
Lo lleve a un tercer mecanico que me dijo que tenia lo siguiente:
la manguera corrugada de la pila de la bomba de gasolina partida la cambie junto con la pila nueva, el filtro interno de la bomba y el filtro de gasolina pero tambien se dio cuenta el tensor de la correa de tiempo estaba mal conectado ya que la bomba de agua estaba tambien mal conectada y por tal motivo el carro estaba fuera de tiempo lo soluciono muy rapido y en efecto el carro prendio de una con mucha fuerza pero cuando le metemos una velocidad el carro se apaga.
Pregunta que puede ser lo que tenga el carro ya le e comprado de todo y continua igual.

Cuando es automático y colocas la palanca en drive y se apaga antes de colocar la palanca desconecta el iac no debería apagarse
de ser así hay esta el problema el mínimo

Buenas noches Jose Gracias por tu respuesta si esa prueba la realice en su oportunidad y estaba dañada y la cambie pero la falla persiste, se apaga el carro cuando pongo una velocidad pareciese que se ahogara el carro ya no se que hacer.
Casi todo se lo e puesto nuevo

Saludos @geronimor

Como dice mi pana @Jose_Millan , para salir de dudas enciende motor y que caliente y regule en mínimo. Desconecta la IAC sin vacilar para que quede inmóvil, el carro debe mantener esas RPM. Ahora prueba a ver qué ocurre al ponerlo en Drive.

El resultado de la prueba descartará si es o no IAC.

Buenos dias @Nino_Rafael saludos
Ya cambie la Valvula IAC, MAP y TPS y la falla continua, prende al toque , tiene buena presion de Gasolina y aguanta el minimo pero al poner una velocidad el carro se apaga como si se ahogara.

A ver qué resulta.